Results 1 to 8 of 8

Thread: Nissan Stentra

  1. #1
    Join Date
    Dec 2006
    Location
    Hamilton(Waterdown)
    Posts
    1,347
    My Mood
    Lurking
    Time Online: 1 Day 2 Hrs 48 Mins 15 Secs
    Avg. Time Online: 5 Secs
    Rep Power
    13

    Nissan Stentra

    my buddy at school has a nissan sentra R or something like that, it has an intake, and header, it runs fine and all but sometimes it wont start.. its been doing this for months, randomly it will only crank, but not fire... then you go back a little while later and vroom fires right up!!!

    it wouldnt start the other day he towed it to CT and they tried it that afternoon and it fired right away...

    Im thinking maybe the CPS?

    can anyone help me out so i can let him know things to try!?!?

    Thanks Steve

  2. #2
    Join Date
    Sep 2007
    Location
    Oshawa
    Posts
    8,005
    My Mood
    Twisted
    Time Online: 3 Wks 6 Days 4 Hrs 27 Mins 52 Secs
    Avg. Time Online: 2 Mins 14 Secs
    Rep Power
    19
    Watch the fuel pressure. The sender will bleed the lines back to the tank and cause a no run. If you key it on a couple of times it should start right up.

  3. #3
    Join Date
    Nov 2007
    Location
    thessalon
    Posts
    314
    Time Online: 1 Wk 23 Hrs 54 Mins 50 Secs
    Avg. Time Online: 39 Secs
    Rep Power
    11
    my dodge avenger with the mits engine and it did it all the time. well all the time kinda. replaced crank sensor and boom fixed, $40 bucks
    92 4.0L HO (sold dwnpmt on a new car for teh wife AFTER OLY HAVING ON THE ROAD FOR 3 WEEKs!!!!!!!!!!!! wow that felt good
    1979 CJ-5 ;ifted with 33's ford 302 4 spd
    I'd ask you to step away from the welder, but it might do the world some good if you clamp the ground electrode to your big toe, put the MIG handle to your temple and pull the trigger.

  4. #4
    Join Date
    Sep 2007
    Location
    Oshawa
    Posts
    8,005
    My Mood
    Twisted
    Time Online: 3 Wks 6 Days 4 Hrs 27 Mins 52 Secs
    Avg. Time Online: 2 Mins 14 Secs
    Rep Power
    19
    There was a cam and crank sensor recall on the 2.5

  5. #5
    Join Date
    Sep 2006
    Location
    Elora, Ontario
    Posts
    205
    My Mood
    Bored
    Time Online: 2 Days 9 Hrs 17 Mins 33 Secs
    Avg. Time Online: 11 Secs
    Rep Power
    12
    This is going to sound retarded, but Nissans are truly finnicky when it comes to voltage. If the battery terminals are dirty, the car won't start. The ECM wants something like 11.376587 volts (+/- 0.456) or it will fail to start. It'll seem dead.

    Although the CPS seems like a good bet too.
    Square headlights rock! []|||||[]

  6. #6
    Join Date
    Dec 2006
    Location
    Hamilton(Waterdown)
    Posts
    1,347
    My Mood
    Lurking
    Time Online: 1 Day 2 Hrs 48 Mins 15 Secs
    Avg. Time Online: 5 Secs
    Rep Power
    13
    Well im not sure which engine it has, its the bigest 4 cylendar engine out there he said so im assuming 2. something... ill let him know about the CPS and crank. Car only has like 60,000km on it and he already blew up one engine in it haha

    It is never dead dead, it just wont fire sometimes, turns over all day long but no spark i guess!

    thanks for the tips guys! deffinatly look into it

    cheers

  7. #7
    Join Date
    Jun 2005
    Location
    Burlington
    Posts
    5,009
    Time Online: 1 Mth 3 Wks 5 Days 8 Hrs 29 Mins 23 Secs
    Avg. Time Online: 4 Mins 37 Secs
    Rep Power
    18
    When it's not firing, you'd need to see if there's a CPS signal to the ECU. Unfortunately that means you'll need to drive around with a good (datastreaming) scanner until it does it. CPS's are common for intermittent failures (4.0, anybody?) causing no-starts.

    If it's cranking all day without starting it's unlikely to be fuel pressure bleed-down.
    ....-Noltz
    '91 Frankenheep Edition. 4.0, 4" BDS, Richmond 8.8, 35" KM2's, Titan 12k, ... gone.
    '95 4Runner SR5. Air-Lift bags, OBA & 8K Winch, DD... gone.

  8. #8
    Join Date
    Dec 2006
    Location
    Hamilton(Waterdown)
    Posts
    1,347
    My Mood
    Lurking
    Time Online: 1 Day 2 Hrs 48 Mins 15 Secs
    Avg. Time Online: 5 Secs
    Rep Power
    13
    ok thanks buddy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •