Results 1 to 5 of 5

Thread: 2007 Dodge Ram

  1. #1
    Join Date
    May 2004
    Location
    Pefferlaw
    Posts
    409
    Time Online: 2 Days 15 Hrs 43 Mins 39 Secs
    Avg. Time Online: 13 Secs
    Rep Power
    14

    2007 Dodge Ram

    It wont start. Battery charged and just makes a ticking sound when key is turned?

  2. #2
    Join Date
    Nov 2009
    Location
    Burlington
    Posts
    293
    My Mood
    Buzzed
    Time Online: 2 Wks 1 Day 5 Hrs 23 Mins 23 Secs
    Avg. Time Online: 1 Min 15 Secs
    Rep Power
    8
    maybe the starter is done.

  3. #3
    Join Date
    May 2009
    Location
    Toronto
    Posts
    157
    My Mood
    Lurking
    Time Online: 2 Wks 2 Days 10 Hrs 10 Mins 17 Secs
    Avg. Time Online: 1 Min 21 Secs
    Rep Power
    9
    Check all the wiring from the battery to the starter and starter to ground
    If that is good,
    Try doing a load test at the battery if you get a reading below 10 volts while cranking for about 10 seconds you need a new battery (Just because a batter shows full voltage while at rest does not mean a battery is good, what is important is what is does when there is a demand placed on it)
    If that is good,
    If you get to this point it is time to take the starter out

    reason for edit
    To clarify a statement, a smartass and unnecessary statement about the solenoid. For all intents and purposes you can think of the starter solenoid as just in internal component of the starter
    Last edited by stuck; 03-20-2010 at 03:40 PM.

  4. #4
    Join Date
    May 2004
    Location
    Pefferlaw
    Posts
    409
    Time Online: 2 Days 15 Hrs 43 Mins 39 Secs
    Avg. Time Online: 13 Secs
    Rep Power
    14
    The solenoid is not separate? I dont know. Its only got 120 km and never given me anytrouble before

  5. #5
    Join Date
    May 2009
    Location
    Toronto
    Posts
    157
    My Mood
    Lurking
    Time Online: 2 Wks 2 Days 10 Hrs 10 Mins 17 Secs
    Avg. Time Online: 1 Min 21 Secs
    Rep Power
    9
    Do you have it solved yet, what was the fix?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •