Results 1 to 15 of 15

Thread: Aztek tranny issues

  1. #1
    Join Date
    Sep 2007
    Location
    Brantford
    Posts
    7,986
    Time Online: 4 Mths 2 Days 17 Hrs 46 Mins 57 Secs
    Avg. Time Online: 10 Mins 5 Secs
    Rep Power
    118

    Aztek tranny issues

    So my 2001 Aztek has been acting up... my issue:

    the tranny doesn't shift into 4th gear.

    It shifts though all the gears smoothly up to then. When I drive with the shifter in D it shifts smoothly but never tries 4th.. the fluid is topped up and it looks good. there is 250+ thousand KM on it.

    any ideas?
    My latest project... Collection of Parts

    Other stuff... Building a doubler, D300 Flip kit

    Quote Originally Posted by Deadman 94 xj View Post
    "Coil springs are for ballpoint pens and pogo sticks".
    ебут раком

  2. #2
    Join Date
    May 2007
    Location
    Brantford
    Posts
    132
    Time Online: 3 Days 10 Hrs 8 Mins 55 Secs
    Avg. Time Online: 16 Secs
    Rep Power
    11
    Is it in limp mode, check engine light on?

  3. #3
    Join Date
    May 2009
    Location
    Toronto
    Posts
    157
    My Mood
    Lurking
    Time Online: 2 Wks 2 Days 10 Hrs 10 Mins 17 Secs
    Avg. Time Online: 1 Min 21 Secs
    Rep Power
    9
    what speed and RPM are you maxing out at?

  4. #4
    Join Date
    May 2009
    Location
    Richmond Hill
    Posts
    3,592
    My Mood
    Twisted
    Time Online: 1 Yr 5 Mths 2 Wks 1 Day 11 Hrs 25 Mins 17 Secs
    Avg. Time Online: 43 Mins 37 Secs
    Rep Power
    12

    Re: Aztek tranny issues

    Keep in mind i don't know my arse. From a hole in the ground... But is that a 4spd auto? If so wouldn't you only get 4th in od?
    2010 JK Unlimited Sahara, rubi axles, 35" duratracs, OME lift: Written off, RIP.
    2006 LJ Rubicon Lots of stuff from TMR installed by CT Motorsports (see profile if you want to know) project once more with feeling
    Quote Originally Posted by igotafrigginjeep View Post
    Listen to the wise Drizit
    Hey he said it not me.
    There Must have been a time when we could have said no.

  5. #5
    Join Date
    Jul 2010
    Location
    Hamilton
    Posts
    298
    My Mood
    Buzzed
    Time Online: 3 Wks 1 Day 2 Hrs 42 Mins 44 Secs
    Avg. Time Online: 1 Min 49 Secs
    Rep Power
    8
    tranny ever been serviced ? filter / oil change?

  6. #6
    Join Date
    May 2009
    Location
    rockwood
    Posts
    208
    My Mood
    Stressed
    Time Online: 3 Wks 6 Hrs 1 Min 57 Secs
    Avg. Time Online: 1 Min 44 Secs
    Rep Power
    9
    there is a valve in the trans that goes bad and in to limp mode and wont let it in to od because it doesn't have enough pressure . Thia vavle is behined the side the side inspection cover and needs to have half the cradle /engin/trans dropped to get to it.


    I just got the guy's at work to do mine was 100 for the pan gasket and 130 for the valve and the labour i don't know about.Any trans shop can check the preshure for you with the right tool

  7. #7
    Join Date
    Sep 2007
    Location
    Brantford
    Posts
    7,986
    Time Online: 4 Mths 2 Days 17 Hrs 46 Mins 57 Secs
    Avg. Time Online: 10 Mins 5 Secs
    Rep Power
    118
    Quote Originally Posted by Maxwell View Post
    Is it in limp mode, check engine light on?
    I have no idea if its in limp mode... the check engine light has been on for 3-4 years and the last time I had it dignosed (about 4 months ago) it was due to some sensor in the gas tank.

    Quote Originally Posted by stuck View Post
    what speed and RPM are you maxing out at?
    well its not maxing out as I don't push it that hard.... but when driving at highway speed (100 Kph) it revs at about 3000 RPM...

    Quote Originally Posted by Drizit View Post
    Keep in mind i don't know my arse. From a hole in the ground... But is that a 4spd auto? If so wouldn't you only get 4th in od?
    yes 4spd auto.... it used to shift into 4th when I would drive normally around town. now when I do HW speeds it pretends like its a 3 spd

    Quote Originally Posted by MudSir View Post
    tranny ever been serviced ? filter / oil change?
    No never has... I check the fluids regularly and It doesn't leak nor has the fluid changed colour

    Quote Originally Posted by giezy View Post
    there is a valve in the trans that goes bad and in to limp mode and wont let it in to od because it doesn't have enough pressure . Thia vavle is behined the side the side inspection cover and needs to have half the cradle /engin/trans dropped to get to it.


    I just got the guy's at work to do mine was 100 for the pan gasket and 130 for the valve and the labour i don't know about.Any trans shop can check the preshure for you with the right tool
    I will look at it tomorrow.... does this seem to be a common issue?

    Will lucas tranny fix help me out here?

    thanks for the info... keep it comin please.

  8. #8
    Join Date
    Jun 2008
    Location
    Ottawa
    Posts
    1,138
    My Mood
    Lurking
    Time Online: 1 Mth 1 Wk 1 Day 12 Hrs 19 Mins 53 Secs
    Avg. Time Online: 3 Mins 10 Secs
    Rep Power
    11
    Change the oil and filter. forget the lucas and other crap until you do that.

  9. #9
    Join Date
    Sep 2007
    Location
    Brantford
    Posts
    7,986
    Time Online: 4 Mths 2 Days 17 Hrs 46 Mins 57 Secs
    Avg. Time Online: 10 Mins 5 Secs
    Rep Power
    118
    ^OK that I will do.....

  10. #10
    Join Date
    Sep 2007
    Location
    Oshawa
    Posts
    8,005
    My Mood
    Twisted
    Time Online: 3 Wks 6 Days 4 Hrs 27 Mins 52 Secs
    Avg. Time Online: 2 Mins 14 Secs
    Rep Power
    19
    Read the DTC's Jimmy. You will have a valve DTC if one isn't tossin fluid in the right directions. You may have all four gears but no torque converter clutch lockup. The TCC solenoid is common in the 4t series trannys. For god sakes man change the fluid and filter.

  11. #11
    Join Date
    May 2009
    Location
    rockwood
    Posts
    208
    My Mood
    Stressed
    Time Online: 3 Wks 6 Hrs 1 Min 57 Secs
    Avg. Time Online: 1 Min 44 Secs
    Rep Power
    9
    be a good to get the trans flushed then drop the pan and do a filter

  12. #12
    Join Date
    Sep 2007
    Location
    Brantford
    Posts
    7,986
    Time Online: 4 Mths 2 Days 17 Hrs 46 Mins 57 Secs
    Avg. Time Online: 10 Mins 5 Secs
    Rep Power
    118
    CC... how do I read the DTC's? this valve thing easy fix?

    and yeah man... I know Fluids... probably this weekend.

    Flush with what?

  13. #13
    Join Date
    Sep 2007
    Location
    Oshawa
    Posts
    8,005
    My Mood
    Twisted
    Time Online: 3 Wks 6 Days 4 Hrs 27 Mins 52 Secs
    Avg. Time Online: 2 Mins 14 Secs
    Rep Power
    19
    Just change the fluid and filter. then repeat 5000 or so later and you should be good for another 60k if nothings burned up. The codes can be read with a simple code reader. To get to the valve body in a 4T40 you need to drop the tranny 1/2 way out of the vanthingy and remove the side cover. Verify the concern first tho.

  14. #14
    Join Date
    May 2009
    Location
    rockwood
    Posts
    208
    My Mood
    Stressed
    Time Online: 3 Wks 6 Hrs 1 Min 57 Secs
    Avg. Time Online: 1 Min 44 Secs
    Rep Power
    9
    Quote Originally Posted by Jak Flash View Post
    CC... how do I read the DTC's? this valve thing easy fix?

    and yeah man... I know Fluids... probably this weekend.

    Flush with what?
    if you go to a shop ask if they have a flush machine they can tap into the cooler lines and change 100% of the fluid with out the pan drop think it was 50$ when i did my jeep then a wek later i dropped the pan and did the filter my self

  15. #15
    Join Date
    Sep 2007
    Location
    Brantford
    Posts
    7,986
    Time Online: 4 Mths 2 Days 17 Hrs 46 Mins 57 Secs
    Avg. Time Online: 10 Mins 5 Secs
    Rep Power
    118
    ^ i ll check that out

    thanks CC... I'll let you guys know how I make out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •