Results 1 to 5 of 5

Thread: dodge ram 3500 van - lost power steering

  1. #1
    Join Date
    Jan 2010
    Location
    Scarborough
    Posts
    342
    Time Online: 3 Mths 2 Wks 3 Days 8 Hrs 29 Mins 57 Secs
    Avg. Time Online: 8 Mins 51 Secs
    Rep Power
    8

    dodge ram 3500 van - lost power steering

    Hey there,
    I haven't looked at it yet in daylight, but my 99 dodge ram cargo can lost the power steering, there's very milky fluid in the reservoir, there is no pump straining sound when i drive and there's no leak currently - however there was a leak with fresh fluid when it happen i was told (a buddy had it) any ideas?

    thanks!
    m.
    OF4WD # 6856
    97 TJ - 101" wb, Clayton triangulated long arm, Bilstein's, Dana 44/hp30 locked w/ chromo's, 4.88's, 4:1 TC, PSC/Currie, 37" Toyo's, rollcage...
    2010 ES 350
    2004 GMC Astro AWD cargo van - 2" lift with 31's

  2. #2
    Stickybongsmoking's Avatar
    Stickybongsmoking is offline Yes, this is gawd damn muthafockling CTD NUT.
    Join Date
    Mar 2009
    Location
    Caistor Centre - Cultural Hub of the universe
    Posts
    4,933
    My Mood
    Buzzed
    Time Online: 10 Mths 3 Wks 5 Days 42 Mins 45 Secs
    Avg. Time Online: 26 Mins 53 Secs
    Rep Power
    28
    Assuming the PS pulley and associated belt is intact, it isn't low on fluid and it didn't blow the high pressure hydraulic hose, then more than likely, the pump shaft broke. They have been known to snap in half and show no physical signs of failure other than a loss of power steering assist.
    A Member of:
    New Frontier 4x4 Club
    OF4WD 4928 & 6687


    1980 CJ Juggy
    2004 GC 4.7 HO Overland

    "Simple, yet functional....like a Sledgehammer"

  3. #3
    Join Date
    Jan 2010
    Location
    Scarborough
    Posts
    342
    Time Online: 3 Mths 2 Wks 3 Days 8 Hrs 29 Mins 57 Secs
    Avg. Time Online: 8 Mins 51 Secs
    Rep Power
    8
    So i've replaced the power teering pump and it's still pretty hard to turn...could something have let go in the steering box?

  4. #4
    Stickybongsmoking's Avatar
    Stickybongsmoking is offline Yes, this is gawd damn muthafockling CTD NUT.
    Join Date
    Mar 2009
    Location
    Caistor Centre - Cultural Hub of the universe
    Posts
    4,933
    My Mood
    Buzzed
    Time Online: 10 Mths 3 Wks 5 Days 42 Mins 45 Secs
    Avg. Time Online: 26 Mins 53 Secs
    Rep Power
    28
    When you say "pretty hard to turn", is it acting like you have no power assist...like when the engine isn't running and you try to turn the wheel? Or do you have some power assist but it is weak?

    You could check if you have return flow from the box to the pump for starters. Does it have hydro boost as well?

  5. #5
    Join Date
    Jan 2010
    Location
    Scarborough
    Posts
    342
    Time Online: 3 Mths 2 Wks 3 Days 8 Hrs 29 Mins 57 Secs
    Avg. Time Online: 8 Mins 51 Secs
    Rep Power
    8
    so it seemed to work itself out - i think there must have been air in the pump/system then...I had a shop do it was i was busy...i think i should find another shop...lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •