Results 1 to 9 of 9

Thread: 2010 ford 150

  1. #1
    Join Date
    May 2011
    Location
    oshawa
    Posts
    27
    Time Online: 1 Day 17 Hrs 40 Mins 16 Secs
    Avg. Time Online: 8 Secs
    Rep Power
    7

    2010 ford 150

    hey everyone soo last week the wife took the truck to get an oil change done at the dealership under " soo many free oil changes" for so many years. and on the way to work this morning hit the brakes and oil light came on truck shut down. waited, restarted got it back to the house, only 1 min away. poped the hood oil is reading on the dip stick. only 28,000 kms on it. and it threw an engine code. is it gonna be one of thos things where i bring it back to the dealership and say everything that needs to be said. ************* and they just say i put oil in it. your good to go. and nothing will come about it. yet the damage has allready been done..

    any thought on what i can say or do thanks alot.

    brodie
    Last edited by brodie720; 09-29-2012 at 08:11 AM.

  2. #2
    Join Date
    Feb 2009
    Location
    Living out of Jeep between Toronto to Owen Sound
    Posts
    2,470
    My Mood
    Tired
    Time Online: 5 Mths 1 Wk 2 Days 12 Hrs 46 Mins 9 Secs
    Avg. Time Online: 13 Mins 9 Secs
    Rep Power
    11
    What are you saying?

    Was there oil?
    badass tj " Hey bro I would really like 2 grab tht rear end."

  3. #3
    Join Date
    Oct 2008
    Location
    Straffordville
    Posts
    312
    Time Online: 1 Mth 1 Wk 3 Days 6 Hrs 1 Min 27 Secs
    Avg. Time Online: 3 Mins 19 Secs
    Rep Power
    9
    I work at a ford dealership as a mechanic and I havent heard of this problem before. Im curious to know what code is stored in the PCM. Did the low oil pressure light come on before the truck stalled or after?? Its normal for a low oil pressure warning message to come up if the engine off and the ignition is on as there is no oil pressure when the engine is not running.

  4. #4
    Join Date
    May 2011
    Location
    oshawa
    Posts
    27
    Time Online: 1 Day 17 Hrs 40 Mins 16 Secs
    Avg. Time Online: 8 Secs
    Rep Power
    7
    oil level is perfect check the pcm. no code was accauly thrown.. plugged in the code reader.. nothing. but my tps is not going with my excellerator. its constanly changing percentages. ive looked on line. alot of complants have been filed.. for excatly the same issue. like hundreds of complates. and the oil symbol came on after it stalled of course wife didnt describe that part lol which makes sense. alot of poeple have had it stall turnin left .. or at a stop light. people have said the mass air flow, throttle body. and needing a second vaccum line in the tank. and there tank is squished.. but no one has really figured it out.cuz after a couple of months it happens again. it seems like ford hasnt figured it out or isnt really concered about it ither.
    thanks alot for your help.

  5. #5
    Join Date
    Jun 2005
    Location
    Burlington
    Posts
    5,009
    Time Online: 1 Mth 3 Wks 5 Days 8 Hrs 29 Mins 23 Secs
    Avg. Time Online: 4 Mins 38 Secs
    Rep Power
    18
    I service dozens of F150's a month and have never heard of this either. Your post is also very unclear, and I'm not sure if you're asking a question or just ranting about the truck?

    Was their oil on the dipstick? If yes, was it low? If no, was there ANYTHING on the dipstick?
    When was the last oil change done? Date and Mileage? Who did it?
    What's the mileage now?
    What exactly did the dealer say?

    While they're no 302 of yesteryear, the 5.4 engines are pretty decent engines. Their most common issue is actually exhaust manifolds cracking or breaking studs, with a distant second being cam phasers (variable cam timing) and that's only if you neglect or use the wrong oil. If the PCM shut it down for low oil pressure, it's a pretty safe bet that no or extremely little damage was done.

    If you have an oil consumption issue, you need to work with your dealer to solve it. Have THEM document the consumption by going in every Friday and having it measured (how much did it take to top up). And remember they're using 5W20 now, considerably thinner than ol' 10W30... consumption IS going to be higher and using 10W30 or even 5W30 will void your warranty for those cam phasers.

    EDIT: You posted as I was writing.

    Are you saying your throttle response is slow? I've heard of this on Chryslers but not Ford (not yet anyway)
    Stalling when turning? Did YOU experience this? That's a safety recall waiting to happen if it's legit.
    Tank is being crushed? Gas tank? Unlikely... those things are TOUGH. There's an emissions vent line, perhaps that's what you mean?

    I'm sorry for asking a bunch of questions, I just don't know what specific question your asking about here.
    Last edited by Noltz; 09-29-2012 at 05:34 PM.
    ....-Noltz
    '91 Frankenheep Edition. 4.0, 4" BDS, Richmond 8.8, 35" KM2's, Titan 12k, ... gone.
    '95 4Runner SR5. Air-Lift bags, OBA & 8K Winch, DD... gone.

  6. #6
    Join Date
    May 2011
    Location
    oshawa
    Posts
    27
    Time Online: 1 Day 17 Hrs 40 Mins 16 Secs
    Avg. Time Online: 8 Secs
    Rep Power
    7
    im very sorry for my uniformative information. it is a 2010, 4.6 with around 30,00km on it. it happened while coasting down a hill just gettin on the brakes a bit cuz of a red light coming up. ive been reasearching on a web site. which ill post a link to. and there are hundreds of poeple havin the same problem..ive talked to ford. and they dont know anything about it. i love this truck. my hole family is a ford family. im not ranting on it. i just want the problem fixed.. it is a huge saftey issue. thats all. http://www-odi.nhtsa.dot.gov/complaints/results.cfm. u can look at everyone with the component sayin anything with "engine" and yes there was one with the gas tank was accualy crushed..
    im sorry again. but thank you for your imput plz bare with me.

    ---------- Post added at 09:05 PM ---------- Previous post was at 09:04 PM ----------

    i thought the web site would have takin u to the excat spot i was at.

  7. #7
    Join Date
    Jun 2005
    Location
    Burlington
    Posts
    5,009
    Time Online: 1 Mth 3 Wks 5 Days 8 Hrs 29 Mins 23 Secs
    Avg. Time Online: 4 Mins 38 Secs
    Rep Power
    18
    We're all here to help each other out... no worries!

    So the engine actually drew enough vacuum on a fuel tank that atmospheric pressure crushed it? That's CRAZY... I'm honestly surprised they'd collapse but I guess if you get right down to 20-22" of vacuum and it's big enough (large walls = more pressure), just wow!

    So downhill, engine is already at idle and at high vacuum due to going downhill, and applying the brake caused the engine to stall. Downhill + high vacuum your engine is going to be running very lean (emissions controls). Brakes do allow a small amount of unmetered air to enter the intake through the booster. It sounds like programing fault where the fuel map does not enrich to compensate when the brakes are pressed. The engine, which is already running lean, is fed a small blast of unmetered air. There's not enough fuel in the mixture when the cylinder fires, and you get a flame out or lean detonate. Hmm...

    I know it's not a "fix", but it sounds like a performance reflash would help here. Something that'll keep the engine running a little richer. I suspect that'll be Ford's answer in a few years too (and you get to pay for it, cuz it's out of warranty).

    Brodie, send me an email on Tuesday when I'm back at work. I'll see what TSB's have been released to Mitchell. You should also contact myles.artus on this site. He works for Ford but I'm not sure what info he has access too.

  8. #8
    Join Date
    May 2011
    Location
    oshawa
    Posts
    27
    Time Online: 1 Day 17 Hrs 40 Mins 16 Secs
    Avg. Time Online: 8 Secs
    Rep Power
    7
    thanks alot for the imput. i really appreciate it. it seems really werid thats for sure. and unsafe. alot of poeple have the problem ither slowing down or turning. but the gas tank that crushed for someone was really werid i kno. i will email u on tuesday. and ill contact myles.artus.
    thanks again.

  9. #9
    Join Date
    Mar 2009
    Location
    burlington
    Posts
    160
    Time Online: 1 Wk 2 Days 18 Hrs 13 Mins 21 Secs
    Avg. Time Online: 48 Secs
    Rep Power
    9
    289-208-1700

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •