Results 1 to 1 of 1

Thread: Need Some input on Liberty Starting Issue

  1. #1
    Join Date
    Mar 2007
    Location
    Barrie, ON
    Posts
    332
    Time Online: 1 Mth 3 Days 3 Hrs 11 Mins 27 Secs
    Avg. Time Online: 2 Mins 43 Secs
    Rep Power
    11

    Need Some input on Liberty Starting Issue

    Basically my 2003 Libby will not turn over.

    I have:
    Installed fresh battery and cleaned posts
    Checked fuses and relays
    Checked the codes, there are none.
    There is no aftermarket remote starter or alarm.
    Inspected wire loom and everything looks great

    When I turn the key, nothing happens. No clicks just silence.
    I did the starter relay jumper test to send power directly to the starter and the starter turns no problem. Leads me to believe the relay in the fuse box is toast but I have tried other relays in there and still...Silence.

    My second thought is ignition switch.
    So I turn the key to ON and then jump the starter and it still will not start. At this point it has no spark.

    I was under the understanding that as long as the dash lights came on as they normally do when you insert the key that your ignition switch was ok.

    So I am thinking maybe Auto trans lock switch.

    What the hell am I missing?

    Any input would be apreciated.
    Last edited by seadog-68; 11-14-2012 at 07:42 PM.
    Condition grounded, but determined to try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •