Results 1 to 2 of 2

Thread: themostat

  1. #1
    Join Date
    Jun 2003
    Location
    Thorold
    Posts
    199
    Time Online: 16 Hrs 18 Mins 39 Secs
    Avg. Time Online: 3 Secs
    Rep Power
    15

    themostat

    I am not expecting miracles cause I know its an old yj but It runs pretty cold so I checked the rad with the cap off and let it run for awhile and noticed the fluid in the rad doesn't seem to be moving or flowing and there is no pressure in the hose although they are warm to the touch is this the thermostat seized closed maybe any ideas thanks

  2. #2
    Join Date
    Oct 2008
    Location
    Guelph
    Posts
    498
    Time Online: 1 Mth 2 Wks 6 Days 5 Hrs 38 Mins 38 Secs
    Avg. Time Online: 4 Mins 7 Secs
    Rep Power
    10
    Depend's on what is in there for a t-stat some are fail safe which will remain open when they are pooched.
    If it is NOT one of these you should be running hot as it will stay closed not letting it recirculate the fluid through the rad.
    Also you have to remember that it has been damn cold out lately and a lot of vehicles will run colder.
    And also again the best way to see the fluid moving is by taking out the T-Stat and then look inside the rad cap hole it should be moving quit a bit. And also without the rad cap on there is no way it will build up pressure as it is now an open container.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •