Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Thread: 95 grand cherokee lerado broken down need help trany just died

Hybrid View

  1. #1
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0

    Angry 95 grand cherokee lerado broken down need help trany just died

    Ok everyone I have 95 ZJ with a 42re trasmission that has just lost every gear except 1st gear I am on Powers Rd. just outside St. Thomas Ontario looking at either help figuring out what has happened to mine ( jeep is my daily driver ) and or a replacement for a good price and close by. you can reach me here but best off texting or calling me direct at ( 613 ) 661-8824. the sooner the better

  2. #2
    Join Date
    Jul 2009
    Location
    London
    Posts
    184
    My Mood
    Relaxed
    Time Online: 1 Wk 1 Day 22 Hrs 13 Mins 34 Secs
    Avg. Time Online: 44 Secs
    Rep Power
    9
    Just seeing this. I presume you got home by now?
    Ron
    '05 GMC Highrider ZR2
    OF4WD#5914

  3. #3
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by Bow_Tied View Post
    Just seeing this. I presume you got home by now?
    Ya we got home with a borrowed car my jeep is still at my dad's on Powers Rd and it will not shift out of first when in drive or when I manually put it in first and shift up first and reverse is all I have

  4. #4
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by Bow_Tied View Post
    Just seeing this. I presume you got home by now?
    Ya we got home with a borrowed car my jeep is still at my dad's on Powers Rd and it will not shift out of first when in drive or when I manually put it in first and shift up first and reverse is all I have

  5. #5
    Join Date
    Jul 2009
    Location
    London
    Posts
    184
    My Mood
    Relaxed
    Time Online: 1 Wk 1 Day 22 Hrs 13 Mins 34 Secs
    Avg. Time Online: 44 Secs
    Rep Power
    9

    95 grand cherokee lerado broken down need help trany just died

    Does it stay in 1st or shift to neutral? Just wondering if it is in limp mode and a battery disconnect would reset it. Though I thought limp mode was second gear...


    Sent from my shoe phone.

  6. #6
    Join Date
    Mar 2009
    Location
    Caistor Centre - Cultural Hub of the universe
    Posts
    4,937
    My Mood
    Buzzed
    Time Online: 10 Mths 3 Wks 5 Days 6 Hrs 28 Mins 58 Secs
    Avg. Time Online: 26 Mins 49 Secs
    Rep Power
    28
    - Check all of the fuses to make sure none are blown. There might be a PCM circuit for tranny control that popped a fuse and could put it in limp mode.

    - Make sure the TV cable didn't break.

    - Check codes. The governor pressure solenoid can be an issue on the 42RE which, when it screws up, I believe may affect the ability for the trans to upshift.
    A Member of:
    New Frontier 4x4 Club
    OF4WD 4928 & 6687


    1980 CJ Juggy
    2004 GC 4.7 HO Overland

    "Simple, yet functional....like a Sledgehammer"

  7. #7
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by CTD NUT View Post
    - Check all of the fuses to make sure none are blown. There might be a PCM circuit for tranny control that popped a fuse and could put it in limp mode.
    .
    checking that next

    Quote Originally Posted by CTD NUT View Post

    - Make sure the TV cable didn't break.
    and this

    Quote Originally Posted by CTD NUT View Post
    -

    - Check codes. The governor pressure solenoid can be an issue on the 42RE which, when it screws up, I believe may affect the ability for the trans to upshift.
    as for the code it might not throw a code just after doing the battery reset??


    Thanks for your ideas

  8. #8
    Join Date
    Mar 2009
    Location
    Caistor Centre - Cultural Hub of the universe
    Posts
    4,937
    My Mood
    Buzzed
    Time Online: 10 Mths 3 Wks 5 Days 6 Hrs 28 Mins 58 Secs
    Avg. Time Online: 26 Mins 49 Secs
    Rep Power
    28
    Quote Originally Posted by ferretman View Post
    as for the code it might not throw a code just after doing the battery reset??
    You might be right but if the conditions that triggered the code are still present after the reset, the code will be triggered again.

  9. #9
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by CTD NUT View Post
    - Check all of the fuses to make sure none are blown. There might be a PCM circuit for tranny control that popped a fuse and could put it in limp mode.

    - Make sure the TV cable didn't break.

    - Check codes. The governor pressure solenoid can be an issue on the 42RE which, when it screws up, I believe may affect the ability for the trans to upshift.

    ok I have the transmission pan off and transmission drained and filter out was thinking about swapping just the governor pressure Solenoid from the parts jeep before I do the transmission swap seeing as I will have to pull the pan and drain it to do the swap anyway . any thoughts whether it will work or not??
    __________________________________________________ ________________________
    I have no problem buying the beer but need a ride to the beer store.

  10. #10
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by Bow_Tied View Post
    Does it stay in 1st or shift to neutral? Just wondering if it is in limp mode and a battery disconnect would reset it. Though I thought limp mode was second gear...


    Sent from my shoe phone.

    I just tried the battery disconnect and it didn't seem to help but not sure if it is in first or second for sure but at 35 km /hr I am hitting 2500-3000 rpm with no hint of a shift no mater what I do. I am going to check the fuses next and go from there and check my service manual for any ideas as I now have access to it when I am at my jeep.

  11. #11
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    ok fuses are all visually good (all that I could find) just took it for another test run after doing the battery reset and now have a bit better idea of what it is doing. ok on test drive it does seem to be in limp mode what feels like first to me but it might be second because I can downshift into first and it does seem to shift into second if I go from drive to second and to first, but if I start out in first and shift to second there is no change and I have nothing above second from what I can tell but this is my first 4x4 and first jeep.

    The TV cable seems fine and in one piece and I just adjusted it again just to make sure it is right . As for the codes I cannot seem to get it to give me a code unless I am doing it wrong. From what I understand it is off, on, off, on, off, on then leave it on but I get no code through the engine light or overdrive light.

    I am willing to try just about everything.

    yes fluid level is good and fluid is clean.

  12. #12
    Join Date
    Dec 2009
    Location
    burlington
    Posts
    347
    My Mood
    Devilish
    Time Online: 1 Wk 3 Days 12 Hrs 36 Mins 58 Secs
    Avg. Time Online: 51 Secs
    Rep Power
    9
    Check the TPS?? if the spring inside is crapped out or the points are messed up. I had my GC stuck in 1st / 2nd gear and it was cause of a faulty TPS. My code ready could not read the voltage but a better scanner could and it showed the TPS not sending out proper signals.
    Birdman
    ditch the bitch! let's go muddin'

  13. #13
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by birdman View Post
    Check the TPS?? if the spring inside is crapped out or the points are messed up. I had my GC stuck in 1st / 2nd gear and it was cause of a faulty TPS. My code ready could not read the voltage but a better scanner could and it showed the TPS not sending out proper signals.
    ummm sorry still working on the proper terminology whats is the TPS and where would I locate it?? sorry for sounding like a newbie

  14. #14
    Join Date
    May 2002
    Location
    Port Elgin
    Posts
    2,634
    My Mood
    Drunk
    Time Online: 3 Mths 3 Wks 3 Hrs 8 Mins 9 Secs
    Avg. Time Online: 9 Mins 8 Secs
    Rep Power
    18
    i believe he is talking throttle position sensor, to me it sounds like a crapped out valve body/solinoid, fluid is still good and its in limp mode, try to get it someplace where you can work on it.
    Last edited by biohazard; 05-12-2014 at 01:56 PM.
    KUSS
    Stupid Fukin Nature
    OF4WD# 2660

  15. #15
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by biohazard View Post
    i believe he is talking throttle position sensor
    thank you I did figurethat much out and have just located it but not sure how to test it or anything at this point.

  16. #16
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by biohazard View Post
    i believe he is talking throttle position sensor, to me it sounds like a crapped out valve body/solinoid, fluid is still good and its in limp mode, try to get it someplace where you can work on it.
    I now have it home to work on it but slow going ( garage not ready )

  17. #17
    Join Date
    Mar 2009
    Location
    Caistor Centre - Cultural Hub of the universe
    Posts
    4,937
    My Mood
    Buzzed
    Time Online: 10 Mths 3 Wks 5 Days 6 Hrs 28 Mins 58 Secs
    Avg. Time Online: 26 Mins 49 Secs
    Rep Power
    28
    ^ I don't think the key cycling to retrieve codes works on a 95 ZJ.

  18. #18
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by CTD NUT View Post
    ^ I don't think the key cycling to retrieve codes works on a 95 ZJ.
    I just tried to get the code and I did get it to work and believe it is coming up with code 12 ( one flash, pause, two close flashes and then it just repeats ) Now to look up what code 12 is.

  19. #19
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    anyone have a good code reader I could borrow that is close by??? I don't even have a volt meter to use right now

  20. #20
    Join Date
    Jul 2009
    Location
    London
    Posts
    184
    My Mood
    Relaxed
    Time Online: 1 Wk 1 Day 22 Hrs 13 Mins 34 Secs
    Avg. Time Online: 44 Secs
    Rep Power
    9

    95 grand cherokee lerado broken down need help trany just died

    If I remember code 12 is battery disconnected. :/ it does sound like limp mode to me. Good luck.


    Sent from my shoe phone.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •