Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27

Thread: 95 grand cherokee lerado broken down need help trany just died

  1. #21
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    just tried disconnecting the TPS and it ran like hell almost died but made no change to the transmission and it threw error code 12, 24, 55

  2. #22
    Join Date
    Nov 2011
    Location
    Owen Sound
    Posts
    21
    Time Online: 1 Mth 1 Wk 2 Days 6 Hrs 8 Mins 46 Secs
    Avg. Time Online: 3 Mins 13 Secs
    Rep Power
    7
    I had a similar problem a couple zj's ago, had 2nd and 3rd only, was a solenoid in the tranny,
    94 zj, 6" long arm lift, 35's

  3. #23
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0

    Wink Daily driver still DOA

    Update my daily driver is still doa with a second problem on top of the tranny now it died when I was limping it home and ended up flat towing it home. I will give more details later on on the new problem

    now for the good news! I found myself a replacement tranny and guess what it came with a whole 96 jeep Grand Cherokee Laredo Wrapped around it!!!!!! and I drove it home! Big Score!!!! a ton of spare parts now

    Click image for larger version. 

Name:	20140513_202026.jpg 
Views:	8 
Size:	105.3 KB 
ID:	96834Click image for larger version. 

Name:	20140513_202100.jpg 
Views:	8 
Size:	95.5 KB 
ID:	96835Click image for larger version. 

Name:	20140513_202112.jpg 
Views:	8 
Size:	121.8 KB 
ID:	96836
    Last edited by ferretman; 05-13-2014 at 11:10 PM.

  4. #24
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    update: daily driver now will run again with new ignition coil but still has transmission problem and jeep is back home and have now got a parts jeep that I might be fixing up to drive as well ( found a transmission with a whole jeep wrapped around it)

  5. #25
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by biohazard View Post
    i believe he is talking throttle position sensor, to me it sounds like a crapped out valve body/solinoid, fluid is still good and its in limp mode, try to get it someplace where you can work on it.
    I now have it home to work on it but slow going ( garage not ready )

  6. #26
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    Quote Originally Posted by CTD NUT View Post
    - Check all of the fuses to make sure none are blown. There might be a PCM circuit for tranny control that popped a fuse and could put it in limp mode.

    - Make sure the TV cable didn't break.

    - Check codes. The governor pressure solenoid can be an issue on the 42RE which, when it screws up, I believe may affect the ability for the trans to upshift.

    ok I have the transmission pan off and transmission drained and filter out was thinking about swapping just the governor pressure Solenoid from the parts jeep before I do the transmission swap seeing as I will have to pull the pan and drain it to do the swap anyway . any thoughts whether it will work or not??
    __________________________________________________ ________________________
    I have no problem buying the beer but need a ride to the beer store.

  7. #27
    Join Date
    Mar 2014
    Location
    Southwold, Ontario Canada
    Posts
    402
    Time Online: 1 Wk 5 Days 23 Hrs 44 Mins 50 Secs
    Avg. Time Online: 1 Min 4 Secs
    Rep Power
    0
    well solenoid is in pan back on with new filter installed filled fluid run through the gears. once checked fluid and repeated until level looked right. pulling it out into the driveway in the morning and letting it warm up for about 20 minutes going through the gears and checking the level before the road test. Any thoughts or suggestions are welcome. But anyway now that my jeep girl isn't under the jeep with me any more it is time for bed. Good night all.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •