Results 1 to 4 of 4

Thread: 2005 jeep tj 4.0L dash gauge lights flashing ?!?! Only half the dash ?

  1. #1
    Join Date
    Oct 2014
    Location
    hamilton/mount hope
    Posts
    124
    Time Online: 3 Days 8 Hrs 40 Mins 16 Secs
    Avg. Time Online: 16 Secs
    Rep Power
    0

    2005 jeep tj 4.0L dash gauge lights flashing ?!?! Only half the dash ?

    So about the beginning of the summer I noticed my gas light (all my bulbs are factory and are red ) was flickering on and off sporadically.
    After about a month I noticed on the opposite side of the dash the coolant light started to flash
    Followed by the temp gauge
    And now half of the main spedo is flashing randomly.
    ALL GAUGES WORK just the BACKLIGHTS FLASH. I checked harness outside jeep in the engine bay and nothing is pinched . Tomorrow I will take dash apart and inspect wires .

    If the bulbs were bad and shot for 4 months now they wouldn't be flickering right??? they just go out I'd assume ? I don't want there to be a electrical issue .... i am attaching pics to show issue please help EXTREMELY annoying . Click image for larger version. 

Name:	Screenshot_20170914-235650.png 
Views:	5 
Size:	448.2 KB 
ID:	104438Click image for larger version. 

Name:	Screenshot_20170914-235725.png 
Views:	5 
Size:	435.8 KB 
ID:	104437Click image for larger version. 

Name:	Screenshot_20170914-235738.png 
Views:	4 
Size:	452.6 KB 
ID:	104436

  2. #2
    Join Date
    Nov 2009
    Location
    Hamilton
    Posts
    4,987
    My Mood
    Blah
    Time Online: 3 Mths 2 Days 12 Hrs 58 Mins 7 Secs
    Avg. Time Online: 7 Mins 36 Secs
    Rep Power
    13
    sounds like either a ground or loose connection...
    a learning experience is one of those things that says, you know that thing you just did...don't do that again.

  3. #3
    Join Date
    May 2009
    Location
    Richmond Hill
    Posts
    3,592
    My Mood
    Twisted
    Time Online: 1 Yr 5 Mths 2 Wks 1 Day 11 Hrs 25 Mins 17 Secs
    Avg. Time Online: 43 Mins 37 Secs
    Rep Power
    12
    Probably a flaky connection at the back of the dash or corrosion in the gauge cluster. Pull it and start looking for green.
    2010 JK Unlimited Sahara, rubi axles, 35" duratracs, OME lift: Written off, RIP.
    2006 LJ Rubicon Lots of stuff from TMR installed by CT Motorsports (see profile if you want to know) project once more with feeling
    Quote Originally Posted by igotafrigginjeep View Post
    Listen to the wise Drizit
    Hey he said it not me.
    There Must have been a time when we could have said no.

  4. #4
    Join Date
    Jun 2003
    Location
    Bowmanville
    Posts
    2,065
    My Mood
    Dead
    Time Online: 2 Wks 12 Hrs 45 Mins 27 Secs
    Avg. Time Online: 1 Min 11 Secs
    Rep Power
    17
    Pull the dash out and bend the tabs on the light sockets a bit. When the lights were changes to red, they may have bent a little on reinstall.
    Wounds heal... Chicks dig scars...

    1984 CJ-8 Scrambler (Rust Free California Edition)
    2005 TJ Unlimited
    1946 Willys CJ-2a "Pa2niA" Featured in JPFreek (click me)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •