Results 1 to 6 of 6

Thread: mid 80`s ferio help needed

  1. #1
    Randy6971 Guest

    mid 80`s ferio help needed

    my friend is having a problem with his car it has a 2.8 tbi, he replaced all the upper gaskets and checked for vacume leaks, the reason he done this is because he couldn`t get the idle to come down below 2k. the car starts good and sounds like its running fine exept the idle is still at 2k.
    Does anyone have any ida why this might be happening and what can be done to fix this????

    Thanks Randy....

  2. #2
    Join Date
    Jul 2004
    Location
    London, ON
    Posts
    4,574
    My Mood
    Yeehaw
    Time Online: 1 Mth 2 Wks 1 Day 1 Hr 19 Mins 2 Secs
    Avg. Time Online: 3 Mins 42 Secs
    Rep Power
    18
    O2 sensor... $25. pull it out, I bet it is all white if he had a head gasket go.
    83 CJ9 LS5.3/4L60E/231/B4R/D300, 8274,D60/14b,ARBs,15"airbags susp, 18"stretch 39"PITBULLS
    09 Nissan
    Ford F350 CrewCab Long box 4x4 TowPIG/dd 165"wheelbase

  3. #3
    Join Date
    Jan 2007
    Location
    Sudbury Ontario
    Posts
    1,133
    Time Online: 6 Days 10 Hrs 27 Mins 10 Secs
    Avg. Time Online: 31 Secs
    Rep Power
    12
    idle air motor seized? try scanning it instead of blindly throwing crap at it .

  4. #4
    Join Date
    Feb 2007
    Location
    oshawa
    Posts
    707
    My Mood
    Twisted
    Time Online: 3 Wks 1 Day 8 Hrs 13 Mins 17 Secs
    Avg. Time Online: 1 Min 50 Secs
    Rep Power
    11
    sounds like an iac motor problem try cleaning it out with some tb cleaner

  5. #5
    Join Date
    Nov 2005
    Location
    Orangeville
    Posts
    1,998
    Time Online: 1 Day 12 Hrs 2 Mins 50 Secs
    Avg. Time Online: 7 Secs
    Rep Power
    14
    i've owned 8 of these cars over the years, a few of the 2.5 TBI's...

    The IAC on this car is horrible it get's gummed up like crazy...

    Check IAC, Check for a plugged EGR valve / EGR Tube.

    Also check for cracked EGR Tube and Cracked Exhaust manifold....

    Usually scanning will give you a good indication, if you plug into the diag port and look at the O2 sensor readings if it pegs out one way or the other even at idle -- you know you have a problem. the O2 should be hunting ever so slightly at idle.
    ----------------------
    Justin
    2012 Subaru WRX STi
    1996 Dodge RAM 1500
    2009 CAN-AM Outlander 650 MAX XT

  6. #6
    Randy6971 Guest
    as it turns out the 02 sensor is good, the egr valve is good, checked that all the vacume lines are tight and not cracked, and while standing at the back of the car i see a gap between the throtle body and the intake turns out that the guy that done the work (<- the owner) had 2 gaskets he though was for the intake so he installed the wrong one i took it apart and the gasket he used looked to me like it may have been for the thermostate lol anyhow the proper gasket went in and the car runs fine.
    Thanks for all the help Randy.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •