Results 1 to 5 of 5

Thread: Brake problem...

  1. #1
    Join Date
    Jun 2005
    Location
    Burlington
    Posts
    5,009
    Time Online: 1 Mth 3 Wks 5 Days 8 Hrs 29 Mins 23 Secs
    Avg. Time Online: 4 Mins 38 Secs
    Rep Power
    18

    Brake problem...

    '00 Intrepid, 4 wheel disc. 170k

    Very little braking - 3x+ stopping distance

    New front rotors & pads, old rears at 50%. Rotors semi-glazed, knocked down with a die grinder & 120 grit disc. Booster holds vacuum after shutdown for a few seconds. Pedal will drop when started (assist). Very slight vacuum noise when applied. Pedal applied hard, all wheels lock (in the air). All calipers not seized, sliding fine.

    Ideas?
    ....-Noltz
    '91 Frankenheep Edition. 4.0, 4" BDS, Richmond 8.8, 35" KM2's, Titan 12k, ... gone.
    '95 4Runner SR5. Air-Lift bags, OBA & 8K Winch, DD... gone.

  2. #2
    Join Date
    Apr 2007
    Location
    Beamsville! Where else?
    Posts
    4,416
    My Mood
    Twisted
    Time Online: 1 Mth 2 Wks 6 Days 18 Hrs 37 Mins 53 Secs
    Avg. Time Online: 4 Mins 10 Secs
    Rep Power
    15
    contaminated rubber in the flex hoses? cheap rotors, contaminated pads (even though they are new), if the packing goop on the rotors is not fully removed the pads will be ruined. internal fluid bypass in the master? did you scuff the pads with the rotors?
    CHARLIE DON'T SURF!!
    DINGA DING DANG, MY DANGA LONG LING LONG
    OF4WD#5576
    BOOYAH!!!

  3. #3
    Join Date
    Jun 2005
    Location
    Burlington
    Posts
    5,009
    Time Online: 1 Mth 3 Wks 5 Days 8 Hrs 29 Mins 23 Secs
    Avg. Time Online: 4 Mins 38 Secs
    Rep Power
    18
    Pads were installed elsewhere. AFAIK, the machining oil was removed before the pads installed. Flex lines are good - pedal hard & pistons retract easily. Rotors appear to be decent, never had no pedal from cheap rotors (warped, yes).

    I rescuffed the surfaces of the rotors, no effect.

  4. #4
    Join Date
    Jul 2003
    Location
    Beamsville
    Posts
    1,043
    My Mood
    Cool
    Time Online: 3 Mths 4 Days 14 Hrs 20 Mins 13 Secs
    Avg. Time Online: 7 Mins 46 Secs
    Rep Power
    16
    Had a similar prob the pads were in backwards. Not sure if it is possibe on this one just a thought
    Professional lunatic
    TJ V3.0 in the works "This is only temporary, unless uhhhh..... it works."
    I get confused once numbers get bigger than I can count on my appendages. I'm only good up to 21!
    one quarter turn before something breaks is a good torque spec.

  5. #5
    Join Date
    Jun 2005
    Location
    Burlington
    Posts
    5,009
    Time Online: 1 Mth 3 Wks 5 Days 8 Hrs 29 Mins 23 Secs
    Avg. Time Online: 4 Mins 38 Secs
    Rep Power
    18
    Found it...

    The booster is leaking on the front side. You can just hear it if the windows are shut and you in a quiet parking lot. "Hissss". It's loosing it's assist, and a big master w/no booster sucks

    Thanks for the suggestions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •